[kodowanie] [unicode] - co jest z ta opera???

Oglądasz wersję archiwalną tematu "[kodowanie] [unicode] - co jest z ta opera???" z forum pl.comp.www



Krzysiek Muszynski - 16 Paź 2004, 11:37
czesc Grupa,

nie przepadam za opera (jest u mnie bardzo niestabilna), ale wychodze z
zalozenia, ze ludzie co jej uzywaja powinni miec mozliwosc ogladania stron,
nie?

no ale teraz poddalem sie.
zajrzyjcie, prosze, *Opera* na http://sfh.pl i powiedzcie mi co jest nie tak
z kodowaniem?
dla ulatwienia link do W3ORG: http://www.w3.org/International/O-charset
i linijka z mojego zrodla:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"

MSIE jak zwykle sobie radzi a Opera wyswietla krzaki - w czym rzecz?
(po recznym przelaczeniu na UTF-8 jest ok)

prosze Was o pomoc.
pzdr,




Sullivan - 16 Paź 2004, 11:55

MSIE jak zwykle sobie radzi



Dziekuje, bo poprawiles mi tym radosnym stwierdzeniem zrypany humor.



Krzysiek Muszynski - 16 Paź 2004, 12:17

| MSIE jak zwykle sobie radzi
Dziekuje, bo poprawiles mi tym radosnym stwierdzeniem zrypany humor.



ok. moze na zla grupe tak smiale stwierdzenie.
moje doswiadczenia wygladaja tak:
MSIE chodzi stabilnie i nigdy nie mialem z nim problemow.
Opera: nie dosc ze ma banner, to srednio raz dziennie sie wykrzacza (gdy
probowalem jej regularnie uzywac).
poza tym ma tez dobre strony, jak np. walidacja HTML czy gesty myszki, ale
<moja prywatna opiniaMSIE jest dla mnie lepszy </moja prywatna opiniai
tyle.

nie chce rozpoczynac jakiegos flame'a czy czegos podobnego.
nie czytam regularnie tej grupy ani nie robie zawodowo WWW - chcialem po
prostu prosic o konstruktywne rozwiazanie mojego problemu.
zapewne to ja robie blad (a nie Twoja ukochana Opera) - ale badz laskawy mi
go wskazac.
pzdr,



Marcin Sztolcman - 16 Paź 2004, 12:25
Dnia sob, 16 paź 2004 o 15:37 GMT,
Krzysiek Muszynski wstukał:

i linijka z mojego zrodla:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"



serwer wysyla naglowek nadpisujacy powyzsza linie. do przegladarki idzie
iso-8859-1

rozwiazanie: skopanie tylka adminowi-lamerowi na tyle mocno, zbey to
wylaczyl
rozwiazanie dwa: jesli masz tam server side, np php, to pomoze funkcje
header()
rozwiazanie trzy: przekonwertuj dokument do iso-8859-1

MSIE jak zwykle sobie radzi a Opera wyswietla krzaki - w czym rzecz?



bo msie jest gupi i ma wszy na pepku (no offence), i olewa standardy ;]

(choc faktem jest ze akurat tutaj userowi idzie to na zdrowie...)

        MySZ




Jan K. - 16 Paź 2004, 12:25

czesc Grupa,



Witam

nie przepadam za opera (jest u mnie bardzo niestabilna), ale wychodze z
zalozenia, ze ludzie co jej uzywaja powinni miec mozliwosc ogladania stron,
nie?



Przeglądarka jak każda inna.

no ale teraz poddalem sie.
zajrzyjcie, prosze, *Opera* na http://sfh.pl i powiedzcie mi co jest nie tak
z kodowaniem?



Nie wiem co jest źle, ale pod linuxem, czym bym nie wszedł
na Twoją stronę, to i tak widzę 'krzaczki'

--
Krzysiek Muszynski
Spisek Fanow Hipopotama
http://sfh.pl
http://imex.sfh.pl



Sig też masz coś nie ten :/



Krzysiek Muszynski - 16 Paź 2004, 12:28

Dnia sob, 16 paź 2004 o 15:37 GMT,
serwer wysyla naglowek nadpisujacy powyzsza linie. do przegladarki idzie
iso-8859-1
rozwiazanie: skopanie tylka adminowi-lamerowi na tyle mocno, zbey to
wylaczyl
rozwiazanie dwa: jesli masz tam server side, np php, to pomoze funkcje
header()



bardzo dziekuje za pomoc.
o to mi chodzilo.
pzdr,



prefiks - 16 Paź 2004, 12:27

zajrzyjcie, prosze, *Opera* na http://sfh.pl i powiedzcie mi co jest nie tak
z kodowaniem?
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"

MSIE jak zwykle sobie radzi a Opera wyswietla krzaki - w czym rzecz?
(po recznym przelaczeniu na UTF-8 jest ok)



Choć ustawiasz kodowanie w źródle strony to twój serwer wysyłając
odpowiedni nagłówek ma na ten temat zupełnie inne zdanie.

PS1. To jest błędne zachowanie msie.
PS2. Popraw delimiter.



Krzysiek Muszynski - 16 Paź 2004, 12:30

Nie wiem co jest źle, ale pod linuxem, czym bym nie wszedł na Twoją
stronę, to i tak widzę 'krzaczki'



dzieki - kolega powyzej wylozyl mi w czym rzecz.

Sig też masz coś nie ten :/



? tego to nie kumam.

pzdr,



PablO - 16 Paź 2004, 12:31

na http://sfh.pl i powiedzcie mi co jest nie tak
z kodowaniem?
dla ulatwienia link do W3ORG: http://www.w3.org/International/O-charset
i linijka z mojego zrodla:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"



Serwer wysyła nagłówek:
Content-Type: text/html; charset=iso-8859-1
I ten jest stosowany przez przeglądarki.



Marcin Sztolcman - 16 Paź 2004, 12:33
Dnia sob, 16 paź 2004 o 16:30 GMT,
Krzysiek Muszynski wstukał:

| Sig też masz coś nie ten :/

? tego to nie kumam.



prawidlowy delimiter powinien wygladac tak: '-- '
czytaj: myslinkmyslnikspacja
u Ciebie jest: '--'
czytaj: myslnikmyslnik

to dosc popularny blad w oe, jak pogoglasz to znajdziesz rozwiazanie jak
to naprawic...

        MySZ


Czy serwer moze wymusic na przegladarce strone kodowa?
kodowanie znakow przesylanych przez formularz
Jakie kodowanie dla nagłówka subject email ?
Dwa kodowania na jednej stronie
  • komputerowe hurtownie
  • Katalog neckerman
  • grom;surf
  • migotanie textur
  • capueirra
  • miraculum woda
  • Wordoffice Pobierz
  • Portugalia Flight
  • program do sciagniecia podkładów piosenek
  • Archiwum tematów z for dyskusyjnych :: Indeks